Rating box disappears upon rating


#1

Continuing the discussion from Update to 0.24.0:

Have to do a full page refresh if you want to re-rate b/c you've made a mistake or something.


#2

Thanks for reporting this! Can you tell me what browser you're using? And are you seeing this behavior on the "System solved!" pop-up, or when you click the "Rate this system" link? (or both)


#3

Currently using chrome (latest version). Sorry for not being more specific, but the bug appears when using "rate this cluster". (not system)

The pop-up doesn't always appear on the system solved pop-up, so I haven't yet found a system to try that.


#4

Very bizarre. Chrome is what we develop in by default. Plus, any system that shows the "Rate this system" link should show the ratings in the system solved pop-up.

Did you happen to do a full refresh (Ctrl+F5)? I'm wondering if Chrome is caching some HTML and JS a bit too rigorously. If so, this wouldn't be the first time, and we might need to see what we can do about that.


#5

Corrections to the pop-up not appearing. The system rating pop-up doesn't appear (assuming that it's a rateable cluster) on @CuCN's systems, but appears on @Bored5555's systems


#6

Even if a cluster is public, its systems might not be. So if you're seeing the ratings display (like this screenshot) on a cluster but not its systems, then those systems aren't public and can't be rated.

If you're on a system or cluster that you've solved and is showing ratings but isn't letting you rate it, then we may have a bug. :grin: