Error messages from saving a solution

Got a recent error message that baffles me.

"Error saving solution:

Tried to activate a hidden port before revealing it!"

The issue is, I had revealed the port, then activated it, which was the only port that was hidden (and the only one that lead to a solution.

This and other errors that I’ve been getting lately only seem to pop up once when editing a system, and then just don’t pop up again for that system. It feels as though the problem fixes itself after the one mistake for that single system, but when a similar situation pops up for another system… here we go again.

As for the other error message I got (forgot to copy/paste it here), I think I can go to a much earlier closed thread where such an error had occurred before for another person. The thread in particular is Lots of errors saving solution , focusing on the very first message.

Full speed, playing on Chrome version 46.0.2490.80 (most recent version).

Decided to make a system that focuses on having multiple actions occurring at once, but mostly being the use of the directory nodes where packets can travel through them (trying to use gaming terminology, but forgot the name of the specific nodes; referring back to the older Exploit game).

We’re currently tracking down an issue relating to multiple flipflops or semaphores linked to the same node. Even when I replay your solution clientside, it only works some of the time.

It might be related to the system state not resetting properly when switching modes from test to edit and back.

We’ll post an update once we figure out just what’s going on.

1 Like

Decided to change that same system again. Probably going to call it ‘Bug finder’ at this point xD

Here’s the error I got:

"Error saving solution:

Solution is invalid."

I had saved the system using one solution, then proceeded to do in a completely different, but more efficient, way, and it resulted in this.

Note: Attempting to repeatedly perform this particular solution always results in this error message. Probably repeatable in the sense that you can have one answer to a system, save it, then before publishing it, make a change to it to have it be solved in a second way, and attempt to publish the cluster using the second type of solution.

Here’s the image of the system in particular, since this is still unpublished (I can publish it, but I plan on using this system to find any bugs).


1 Like

There are other moments where the screen continues to load indefinitely (or so it seems) after successfully completing an unpublished system, as though it was trying to determine whether or not the solution is valid or not. I’m assuming that it’s possible to cause the system to time out, or something like that?

Details: Intentionally creating a system that attempts to cause something of an overload of information, causing the game to slow down due to the huge number of packets being generated in the level. It still requires user input to complete the level. All my testing and working with the systems is done at full speed. Not sure if this causes a problem with publishing “an unfinished draft of an existing system.” I cannot save anything in this state, so any progress that I put into the system when this happens is lost.

The backend does in fact simulate the solution, so intentional efforts to make it take a long time will work.

If you’re deliberately making a system that you suspect will cause a problem, I’d suggest saving it without solving it first so that you don’t lose any progress if the solution fails.

Yeah, just for this system it is intentional. There are moments, however, in other systems where it isn’t intentional, and it happens anyways.

We’ve fixed this issue, we think. When solving a draft system, the client was sending the hash for the original version. It looks like the various errors you were getting were the result of your solutions being replayed using the wrong system data.

Yeah, this fixed the issue. And now I found another issue, but with no error message. When attempting to publish an unfinished draft of an existing system (one that also intentionally makes the system take a long time to simulate the solution), I get the System Solved screen, but it fails to publish the draft.

Note: This issue seems to come and go. Sometimes I get the issue above, other times I have no issues at all. I think it has to do with the length of time taken to reach the solution. If I have impeccable timing, I might be able to work around the issue.

Not sure how much time elapses between one that can be borderline in between working and failing (despite showing that it worked), but I have reason to believe that the answer has to be below 3-5 minutes in regards to all the actions performed to simulate the entire solution.

We’ve got the publishing issue logged in our tracker. Thanks for reporting it! It’s going to be a few days before we can diagnose and resolve it.

Just to confirm: you solve the puzzle, hit the “Publish” button, and nothing happens? (Drafts don’t auto-publish when you solve them.)

I solve the puzzle (saved before solving), get the System Solved message, but the “Publish” button does not show up. Forgot to clarify that part up.

You have to be in Test mode for the solution to save with the edited puzzle.

Try doing the following steps:

  1. Click “Edit System” to go into edit mode.
  2. Click “Test System”.
  3. Solve the puzzle.
  4. Click “Save System”.

You should then get the publish button.

Hmm… did not know that I had to save the system after completing the draft of the puzzle to trigger the Publish button. I usually save, then test, then solve. I rarely ever think to save again, unless I wasn’t sure on whether the changes I made caused the system to become impossible (in which case I do end up following that list of directions unconsciously).

Note: Thanks for the help with this FPG, gregory, and Melissa. :smile:

Okay. We’ll consider this issue closed for now. We already have in our backlog to work on the user experience around drafting and publishing, but it looks like there’s no bug here.