Can't Make System Public


#1

I have another bug that may just be a result of my incompetence. I have created a new system and solved it at least 4 times, but I am still getting the message saying that I must test it and provide a solution before I can make it public. I have not edited anything in between solutions, other than the Welcome Banner and its twin, so I do not know what to do to fix it. Any help you could provide would be appreciated.


Status of System Wiring Issue
#2

Just to make sure: you were in test mode, solved it, and clicked the "save" button?

What's the name of the system?


#3

That is correct, although I was required to go back into editing mode in order to save it again. The name of the system is currently "Spiral 2.0".


#4

Are you following these steps?

  1. Click "Edit System."
  2. Click "Test System."
  3. Solve the system.
  4. Click "Save System."

At the moment, if you solve a system, then click into edit mode, the solution won't be saved as a canon one. This experience will improve over time.


#5

There is not a save button available for the system except in Editing mode. My only option in testing mode is to go back to Editing mode.


#6

I don't see any errors in our logs that could be related to this issue. When you solve the system in Test mode and the Save button does not appear, does anything else unusual happen?

Do you see any error messages? You can open the developer console by hitting F12; the Console there may show some errors that will help us diagnose.


#7

Rather than displaying the message I gave for the end of the system, it displays a message box saying "System Complete!", with only an option to close the message box. Other than that, there are no error messages. Unfortunately, I mainly use an Acer Chromebook, which does not include the F1-F12 keys. However, I am able to view the source code for the page, if that provides any help.


#8

Are you totally sure that when you're solving the system, you're doing so in Test mode? There's no way that message box should be showing in Test mode.


#9

I am sure. When I open the system, it is already in Test mode. I also tried going back to Editing mode and returning to Test mode, but that gave me the same result.


#10

You're not in Test mode. You need to manually go into Test mode.

When you first open a system, it's in Play mode. Systems solved in Play mode don't save canon solutions from creators, to let you play with the system without changing the baseline for other solvers. Canon solutions are only saved when you go through Edit mode into Test mode.

You must follow the numbered steps above in order to save a canon solution. If you do so, you should not see the "System Complete" message when solving. If you see the "System Complete" message, you're not in Test mode.

We recognize that the game doesn't make this process clear, and we'll be improving it as we work on the game.


#11

Edit: I apologize for wasting your time. Apparently, when the system is reloaded in Test mode, it returns to Play mode. As I was unaware of this, I had naively assumed that the error was with the game itself, rather than my own incompetency. Again, I apologize.


#12

Like I said, we need to make this process clearer! :sweat_smile: Thank you for your patience with our alpha interface clumsiness.


#13

Of course. Thank you for your help.